Click or drag to resize

BinaryArchiveWriterBeginWrite3dmChunk Method (UInt32, Int32, Int32)

Begins writing a chunk

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public bool BeginWrite3dmChunk(
	uint typecode,
	int majorVersion,
	int minorVersion
)

Parameters

typecode
Type: SystemUInt32
chunk's typecode
majorVersion
Type: SystemInt32

[Missing <param name="majorVersion"/> documentation for "M:Rhino.FileIO.BinaryArchiveWriter.BeginWrite3dmChunk(System.UInt32,System.Int32,System.Int32)"]

minorVersion
Type: SystemInt32

[Missing <param name="minorVersion"/> documentation for "M:Rhino.FileIO.BinaryArchiveWriter.BeginWrite3dmChunk(System.UInt32,System.Int32,System.Int32)"]

Return Value

Type: Boolean
True if input was valid and chunk was started. In this case you must call EndWrite3dmChunk(), even if something goes wrong while you attempt to write the contents of the chunk. False if input was not valid or the write failed.
See Also