Click or drag to resize

CurveList Methods

The CurveList type exposes the following members.

Methods
  NameDescription
Public methodAdd(Arc)
Adds an arc to this list.
Public methodAdd(Circle)
Adds a circle to this list.
Public methodAdd(Ellipse)
Adds an ellipse to this list.
Public methodAdd(IEnumerablePoint3d)
Adds a polyline to this list.
Public methodAdd(Line)
Adds a line to this list.
Public methodInsert(Int32, Arc)
Inserts an arc at a given index of this list.
Public methodInsert(Int32, Circle)
Inserts a line at a given index of this list.
Public methodInsert(Int32, Ellipse)
Inserts an ellipse at a given index of this list.
Public methodInsert(Int32, Line)
Inserts a line at a given index of this list.
Public methodInsert(Int32, IEnumerablePoint3d)
Inserts a polyline at a given index of this list.
Public methodTransform
Transform all the curves in this list. If at least a single transform failed this function returns false.
Top
See Also