Click or drag to resize

OsnapModes Enumeration

Defines several bit masks for each of the OSnap that are defined.

Refer to the Rhino Help file for further information.

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
[FlagsAttribute]
public enum OsnapModes
Members
  Member nameValueDescription
None0No OSnap.
Near2Near OSnap.
Focus8Focus OSnap.
Center32Center OSnap.
Vertex64Vertex OSnap.
Knot128Knot OSnap.
Quadrant512Quadrant OSnap.
Midpoint2048Midpoint OSnap.
Intersection8192Intersection OSnap.
End131072End OSnap.
Perpendicular524288Perpendicular OSnap.
Tangent2097152Tangent OSnap.
Point134217728Point OSnap.
See Also