Click or drag to resize

CurvatureGraphSettings Class

Contains static methods and properties to modify curvature graph commands.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsCurvatureGraphSettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class CurvatureGraphSettings

The CurvatureGraphSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberCurveHairColor
Gets or sets the curve hair color;
Public propertyStatic memberHairDensity
Gets or sets the hair density;
Public propertyStatic memberHairScale
Gets or sets the hair scale;
Public propertyStatic memberSampleDensity
Gets or sets the sampling density;
Public propertyStatic memberSrfUHair
Gets or sets the surface U hairs are on;
Public propertyStatic memberSrfVHair
Gets or sets the surface V hairs are on;
Public propertyStatic memberSurfaceUHairColor
Gets or sets the surface U hair color;
Public propertyStatic memberSurfaceVHairColor
Gets or sets the surface V hair color;
Top
Methods
  NameDescription
Public methodStatic memberGetCurrentState
Gets the current settings of the application.
Public methodStatic memberGetDefaultState
Gets the factory settings of the application.
Public methodStatic memberRestoreDefaults
Commits the default settings as the current settings.
Public methodStatic memberUpdateFromState
Sets all settings to a particular defined joined state.
Top
See Also