Click or drag to resize

NeverRepeatList Class

Contains static methods and properties relating to the list of commands that are never repeated.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsNeverRepeatList

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class NeverRepeatList

The NeverRepeatList type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberUseNeverRepeatList
Only use the list if somebody modifies it via CRhinoAppSettings::SetDontRepeatCommands(). Return value of true means CRhinoCommand don't repeat flags will be ignored and the m_dont_repeat_list will be used instead. false means the individual CRhinoCommands will determine if they are repeatable.
Top
Methods
  NameDescription
Public methodStatic memberCommandNames
The list of commands to not repeat.
Public methodStatic memberSetList
Puts the command name tokens in m_dont_repeat_list.
Top
See Also