Click or drag to resize

FileSettings Class

Contains static methods and properties relating Rhino files.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsFileSettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class FileSettings

The FileSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAutoSaveEnabled
Enables or disables Rhino's automatic file saving mechanism.
Public propertyStatic memberAutoSaveFile
the file name used by Rhino's automatic file saving mechanism.
Public propertyStatic memberAutoSaveInterval
how often the document will be saved when Rhino's automatic file saving mechanism is enabled.
Public propertyStatic memberAutoSaveMeshes
save render and display meshes in autosave file.
Public propertyStatic memberClipboardCopyToPreviousRhinoVersion
Gets or sets a value that decides if copies to the clipboard are performed in both the current and previous Rhino clipboard formats. This means you will double the size of what is saved in the clipboard but will be able to copy from the current to the previous version using the clipboard.
Public propertyStatic memberClipboardOnExit
Gets or sets a value that determines what to do with clipboard data on exit.
Public propertyStatic memberCreateBackupFiles
Gets or sets a value that controls the creation of backup files.
Public propertyStatic memberDefaultRuiFile
Gets the path to the default RUI file.
Public propertyStatic memberExecutableFolder
Returns the directory where the main Rhino executable is located.
Public propertyStatic memberFileLockingEnabled
Ensure that only one person at a time can have a file open for saving.
Public propertyStatic memberFileLockingOpenWarning
Gets or sets whether to display the information dialog which identifies computer files.
Public propertyStatic memberHelpFilePath
Gets the Rhino help file path.
Public propertyStatic memberInstallFolder
Returns Rhino's installation folder.
Public propertyStatic memberLocalProfileDataFolder
Get full path to a Rhino specific sub-folder under the per-user Local (non-roaming) Profile folder. This is the folder where user-specific data is stored. On Windows 7, 8, usually someplace like: "C:\Users\[USERNAME]\AppData\Local\McNeel\Rhinoceros\[VERSION_NUMBER]\"
Public propertyStatic memberSaveViewChanges
true for users who consider view changes a document change.
Public propertyStatic memberSearchPathCount
Gets the amount of search paths that are currently defined.
Public propertyStatic memberTemplateFile
Returns or sets the location of Rhino's template file.
Public propertyStatic memberTemplateFolder
Returns or sets the location of Rhino's template files.
Public propertyStatic memberWorkingFolder
Returns or sets Rhino's working directory, or folder. The working folder is the default folder for all file operations.
Top
Methods
  NameDescription
Public methodStatic memberAddSearchPath
Adds a new imagePath to Rhino's search imagePath list. See "Options Files settings" in the Rhino help file for more details.
Public methodStatic memberAutoSaveBeforeCommands
Input list of commands that force AutoSave prior to running.
Public methodStatic memberDefaultTemplateFolderForLanguageID
Returns the default template folder for a given language id.
Public methodStatic memberDeleteSearchPath
Removes an existing imagePath from Rhino's search imagePath list. See "Options Files settings" in the Rhino help file for more details.
Public methodStatic memberFindFile
Searches for a file using Rhino's search imagePath. Rhino will look for a file in the following locations: 1. The current document's folder. 2. Folder's specified in Options dialog, File tab. 3. Rhino's System folders.
Public methodStatic memberGetCurrentState
Returns the current state.
Public methodStatic memberGetDataFolder
Gets the data folder for machine or current user.
Public methodStatic memberGetDefaultState
Returns the default state.
Public methodStatic memberGetSearchPaths
Returns all of the imagePath items in Rhino's search imagePath list. See "Options Files settings" in the Rhino help file for more details.
Public methodStatic memberRecentlyOpenedFiles
Returns a list of recently opened files. Note that this function does not check to make sure that these files still exist.
Public methodStatic memberSetAutoSaveBeforeCommands
Set list of commands that force AutoSave prior to running.
Public methodStatic memberUpdateFromState
Sets all settings to a particular defined joined state.
Top
See Also