Click or drag to resize

FileSettings Methods

The FileSettings type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAddSearchPath
Adds a new imagePath to Rhino's search imagePath list. See "Options Files settings" in the Rhino help file for more details.
Public methodStatic memberAutoSaveBeforeCommands
Input list of commands that force AutoSave prior to running.
Public methodStatic memberDefaultTemplateFolderForLanguageID
Returns the default template folder for a given language id.
Public methodStatic memberDeleteSearchPath
Removes an existing imagePath from Rhino's search imagePath list. See "Options Files settings" in the Rhino help file for more details.
Public methodStatic memberFindFile
Searches for a file using Rhino's search imagePath. Rhino will look for a file in the following locations: 1. The current document's folder. 2. Folder's specified in Options dialog, File tab. 3. Rhino's System folders.
Public methodStatic memberGetCurrentState
Returns the current state.
Public methodStatic memberGetDataFolder
Gets the data folder for machine or current user.
Public methodStatic memberGetDefaultState
Returns the default state.
Public methodStatic memberGetSearchPaths
Returns all of the imagePath items in Rhino's search imagePath list. See "Options Files settings" in the Rhino help file for more details.
Public methodStatic memberRecentlyOpenedFiles
Returns a list of recently opened files. Note that this function does not check to make sure that these files still exist.
Public methodStatic memberSetAutoSaveBeforeCommands
Set list of commands that force AutoSave prior to running.
Public methodStatic memberUpdateFromState
Sets all settings to a particular defined joined state.
Top
See Also