Click or drag to resize

CurvatureAnalysisSettings Class

Contains static methods and properties to modify curvature analysis-related commands.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsCurvatureAnalysisSettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class CurvatureAnalysisSettings

The CurvatureAnalysisSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberGaussRange
Gets or sets the Gaussian curvature range.
Public propertyStatic memberMaxRadiusRange
Gets or sets the Maximum Radius curvature range.
Public propertyStatic memberMeanRange
Gets or sets the Mean curvature range.
Public propertyStatic memberMinRadiusRange
Gets or sets the Minimum Radius curvature range.
Public propertyStatic memberStyle
Gets or sets the curvature analysis style.
Top
Methods
  NameDescription
Public methodStatic memberCalculateCurvatureAutoRange
Public methodStatic memberGetCurrentState
Gets the current settings of the application.
Public methodStatic memberGetDefaultState
Gets the factory settings of the application.
Public methodStatic memberRestoreDefaults
Commits the default settings as the current settings.
Public methodStatic memberUpdateFromState
Sets all settings to a particular defined joined state.
Top
See Also