Click or drag to resize

ChooseOneObjectSettingsState Class

Represents a snapshot of ChooseOneObjectSettings.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsChooseOneObjectSettingsState

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public class ChooseOneObjectSettingsState

The ChooseOneObjectSettingsState type exposes the following members.

Properties
  NameDescription
Public propertyAutomaticResize
AutomaticResize
Public propertyDynamicHighlight
DynamicHighlight
Public propertyFollowCursor
FollowCursor
Public propertyHighlightColor
HighlightColor
Public propertyMaxAutoResizeItems
MaxAutoResizeItems
Public propertyShowAllOption
ShowAllOption
Public propertyShowObjectColor
ShowObjectColor
Public propertyShowObjectLayer
ShowObjectLayer
Public propertyShowObjectName
ShowObjectName
Public propertyShowObjectType
ShowObjectType
Public propertyShowObjectTypeDetails
ShowObjectTypeDetails
Public propertyShowTitlebarAndBorder
ShowTitlebarAndBorder
Public propertyUseCustomColor
UseCustomColor
Public propertyXOffset
XOffset
Public propertyYOffset
YOffset
Top
Methods
  NameDescription
Top
See Also