Click or drag to resize

ChooseOneObjectSettings Class

Contains static methods and properties to modify "choose one object" settings.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsChooseOneObjectSettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public static class ChooseOneObjectSettings

The ChooseOneObjectSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAutomaticResize
AutomaticResize
Public propertyStatic memberDynamicHighlight
DynamicHighlight
Public propertyStatic memberFollowCursor
FollowCursor
Public propertyStatic memberHighlightColor
HighlightColor
Public propertyStatic memberMaxAutoResizeItems
MaxAutoResizeItems
Public propertyStatic memberShowAllOption
ShowAllOption
Public propertyStatic memberShowObjectColor
ShowObjectColor
Public propertyStatic memberShowObjectLayer
ShowObjectLayer
Public propertyStatic memberShowObjectName
ShowObjectName
Public propertyStatic memberShowObjectType
ShowObjectType
Public propertyStatic memberShowObjectTypeDetails
ShowObjectTypeDetails
Public propertyStatic memberShowTitlebarAndBorder
ShowTitlebarAndBorder
Public propertyStatic memberUseCustomColor
UseCustomColor
Public propertyStatic memberXOffset
XOffset
Public propertyStatic memberYOffset
YOffset
Top
Methods
  NameDescription
Public methodStatic memberGetCurrentState
Gets the current settings of the application.
Public methodStatic memberGetDefaultState
Gets the factory settings of the application.
Public methodStatic memberRestoreDefaults
Commits the default settings as the current settings.
Public methodStatic memberUpdateFromState
Sets all settings to a particular defined joined state.
Top
See Also