Click or drag to resize

GeneralSettings Class

Contains static methods and properties to give access to Rhinoceros settings.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsGeneralSettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class GeneralSettings

The GeneralSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAutoUpdateCommandHelp
Command help dialog auto-update feature.
Public propertyStatic memberContextMenuDelay
Time to wait before permitting context menu display.
Public propertyStatic memberEnableContextMenu
true if right mouse down + delay will pop up context menu on a mouse up if no move happens.
Public propertyStatic memberMaximumPopupMenuLines
Gets or sets the maximum number of popup menu lines.
Public propertyStatic memberMaximumUndoMemoryMb
Gets or sets the minimum undo memory Mb.

Undo records will be purged if there are more than MinimumUndoSteps and they use more than MaximumUndoMemoryMb.

Public propertyStatic memberMiddleMouseMacro
Gets or sets the toolbar to popup when the middle mouse is clicked on a view, this value is only used when MiddleMouseMode is set to PopupToolbar.
Public propertyStatic memberMiddleMouseMode
Gets or sets what happens when the user clicks the middle mouse.
Public propertyStatic memberMiddleMousePopupToolbar
Gets or sets the toolbar to popup when the middle mouse is clicked on a view, this value is only used when MiddleMouseMode is set to PopupToolbar.
Public propertyStatic memberMinimumUndoSteps
Gets or sets the minimum undo steps.

Undo records will be purged if there are more than MinimumUndoSteps and they use more than MaximumUndoMemoryMb.

Public propertyStatic memberMouseSelectMode
Gets or sets the current selection mode.
Public propertyStatic memberNewObjectIsoparmCount
Gets or sets the number of isoparm curves to show on new objects.
Public propertyStatic memberUseExtrusions
Should extrusion objects be created for things like cylinders
Top
Methods
  NameDescription
Public methodStatic memberGetCurrentState
Gets the current settings.
Public methodStatic memberGetDefaultState
Gets the factory settings.
Top
See Also