Click or drag to resize

OpenGLSettings Class

Static methods and properties to control OpenGL settings
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsOpenGLSettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class OpenGLSettings

The OpenGLSettings type exposes the following members.

Constructors
  NameDescription
Public methodOpenGLSettings
Initializes a new instance of the OpenGLSettings class
Top
Properties
  NameDescription
Public propertyStatic memberAntialiasLevel
Gets or sets the anti-alias level used by OpenGL viewports
Top
Methods
  NameDescription
Public methodStatic memberGetCurrentState
Gets the current settings.
Public methodStatic memberGetDefaultState
Gets the OpenGL factory settings.
Public methodStatic memberRestoreDefaults
Updates from the default setting state.
Public methodStatic memberUpdateFromState
Updates from a particular setting state.
Top
See Also