Click or drag to resize

SmartTrackSettingsState Class

Represents a snapshot of SmartTrackSettings.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsSmartTrackSettingsState

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SmartTrackSettingsState

The SmartTrackSettingsState type exposes the following members.

Properties
  NameDescription
Public propertyActivationDelayMilliseconds
Gets or sets the activation delay in milliseconds.
Public propertyActivePointColor
Gets or sets the active point color.
Public propertyLineColor
Gets or sets the smart track line color.
Public propertyStatic memberMaxSmartPoints
Gets or sets the maximum number of smart points.
Public propertyPointColor
Gets or sets the point color.
Public propertySmartOrtho
Gets or sets a value indicating if the 'Smart Ortho' feature is active.
Public propertySmartTangents
Gets or sets a value indicating if the 'Smart Tangents' feature is active.
Public propertyTanPerpLineColor
Gets or sets the tangent and perpendicular line color.
Public propertyUseDottedLines
Gets or sets a value indicating if lines are drawn dotted.
Public propertyUseSmartTrack
Gets or sets if the 'smart track' feature is active.
Top
Methods
  NameDescription
Top
See Also