SmartTrackSettings Class |
Namespace: Rhino.ApplicationSettings
The SmartTrackSettings type exposes the following members.
Name | Description | |
---|---|---|
![]() ![]() | ActivationDelayMilliseconds | Gets or sets the activation delay in milliseconds. |
![]() ![]() | ActivePointColor | Gets or sets the active point color. |
![]() ![]() | LineColor | Gets or sets the smart track line color. |
![]() ![]() | MaxSmartPoints | Gets or sets the maximum number of smart points. |
![]() ![]() | PointColor | Gets or sets the point color. |
![]() ![]() | SmartOrtho | Gets or sets a value indicating if the 'Smart Ortho' feature is active.
Orthogonal lines are then drawn automatically. |
![]() ![]() | SmartTangents | Gets or sets a value indicating if the 'Smart Tangents' feature is active. |
![]() ![]() | TanPerpLineColor | Gets or sets the tangent and perpendicular line color. |
![]() ![]() | UseDottedLines | Gets or sets a value indicating if lines are drawn dotted. |
![]() ![]() | UseSmartTrack | Gets or sets if the Smart Track feature is active. |
Name | Description | |
---|---|---|
![]() ![]() | GetCurrentState |
Gets the current settings.
|
![]() ![]() | GetDefaultState |
Gets the Smart Track factory settings.
|
![]() ![]() | UpdateFromState |
Updates from a particular setting state.
|