Click or drag to resize

SelectionFilterSettings Class

Selection filter settings restrict any selection mode (SelWindow, SelCrossing, SelAll, etc.) to specified object types. Note, selection filter settings are not persistent.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsSelectionFilterSettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class SelectionFilterSettings

The SelectionFilterSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberEnabled
Enables or disables the global object selection filter.
Public propertyStatic memberGlobalGeometryFilter
The global geometry type filter controls which types of geometry will be filtered. Note, the filter can be a bitwise combination of multiple object types.
Public propertyStatic memberOneShotGeometryFilter
The one-shot geometry type filter controls which types of geometry will be filtered for one selection. Note, the filter can be a bitwise combination of multiple object types.
Public propertyStatic memberSubObjectSelect
Enables or disabled sub-object selection.
Top
Methods
  NameDescription
Public methodStatic memberGetCurrentState
Gets the current settings of the application.
Public methodStatic memberGetDefaultState
Gets the factory settings of the application.
Public methodStatic memberRestoreDefaults
Commits the default settings as the current settings.
Public methodStatic memberUpdateFromState
Sets all settings to a particular defined joined state.
Top
See Also