Click or drag to resize

HistorySettings Class

Provides static (Shared in Vb.Net) properties to modify Rhino History settings.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsHistorySettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class HistorySettings

The HistorySettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberBrokenRecordWarningEnabled
Displays a warning dialog when an action is taken that breaks the link between the output and input objects.
Public propertyStatic memberObjectLockingEnabled
When history object locking is enabled, objects with history on them act as if they were locked and the only way to modify these objects is to edit their inputs.
Public propertyStatic memberRecordingEnabled
When history recording is enabled, new objects keep a record of how they were constructed so that they can be updated if an input object changes.
Public propertyStatic memberRecordNextCommand
Enable history recording until the end of the next command
Public propertyStatic memberUpdateEnabled
When history update is enabled, dependent objects are automatically updated when an antecedent is modified.
Top
See Also