Click or drag to resize

EdgeAnalysisSettings Class

Contains static methods and properties to modify the visibility of edges in edge-related commands.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsEdgeAnalysisSettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class EdgeAnalysisSettings

The EdgeAnalysisSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberShowEdgeColor
Gets or sets a color used to enhance display edges in commands like _ShowEdges and _ShowNakedEdges.
Public propertyStatic memberShowEdges
Gets or sets a value referring to the group of edges that are targeted.

0 = all.

1 = naked.

2 = non-manifold.

Top
Methods
  NameDescription
Public methodStatic memberGetCurrentState
Gets the current settings of the application.
Public methodStatic memberGetDefaultState
Gets the factory settings of the application.
Public methodStatic memberRestoreDefaults
Commits the default settings as the current settings.
Public methodStatic memberUpdateFromState
Sets all settings to a particular defined joined state.
Top
See Also