Click or drag to resize

SelectionFilterSettingsState Class

Represents a snapshot of SelectionFilterSettings.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsSelectionFilterSettingsState

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SelectionFilterSettingsState

The SelectionFilterSettingsState type exposes the following members.

Properties
  NameDescription
Public propertyEnabled
Enables or disables the global object selection filter.
Public propertyGlobalGeometryFilter
The global geometry type filter controls which types of geometry will be filtered. Note, the filter can be a bitwise combination of multiple object types.
Public propertyOneShotGeometryFilter
The one-shot geometry type filter controls which types of geometry will be filtered for one selection. Note, the filter can be a bitwise combination of multiple object types.
Public propertySubObjectSelect
Enables or disabled sub-object selection.
Top
Methods
  NameDescription
Top
See Also