Click or drag to resize

AppearanceSettings Class

Provides static methods and properties to deal with the appearance of the application.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsAppearanceSettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class AppearanceSettings

The AppearanceSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberCommandPromptBackgroundColor
Gets or sets the color of the command prompt background.
Public propertyStatic memberCommandPromptFontSize
Size of font used in command prompt (in points)
Public propertyStatic memberCommandPromptHypertextColor
Gets or sets the color of the command prompt hypertext.
Public propertyStatic memberCommandPromptPosition
Gets or sets the command prompt position.
Public propertyStatic memberCommandPromptTextColor
Gets or sets the color of the command prompt text.
Public propertyStatic memberCrosshairColor
Gets or sets the color of the crosshair icon.
Public propertyStatic memberCurrentLayerBackgroundColor
Gets or sets the color used by the layer manager dialog as the background color for the current layer.
Public propertyStatic memberDefaultFontFaceName
Gets or sets the default font face name used in Rhino.
Public propertyStatic memberDefaultLayerColor
Gets or sets the default layer color.
Public propertyStatic memberDefaultObjectColor
Gets or sets the default color for new objects.
Public propertyStatic memberDirectionArrowIconHeadSize
length of direction arrowhead icon in pixels.
Public propertyStatic memberDirectionArrowIconShaftSize
length of direction arrow shaft icon in pixels.
Public propertyStatic memberEchoCommandsToHistoryWindow
Gets or sets a value that determines if command names are written to the history window.
Public propertyStatic memberEchoPromptsToHistoryWindow
Gets or sets a value that determines if prompt messages are written to the history window.
Public propertyStatic memberEditCandidateColor
Gets or sets the color of objects that are eligible to be edited.
Public propertyStatic memberFeedbackColor
Gets or sets the feedback color.
Public propertyStatic memberFrameBackgroundColor
Gets or sets the background color of the frame.
Public propertyStatic memberGridThickLineColor
Gets or sets the color of the thick line of the grid.
Public propertyStatic memberGridThinLineColor
Gets or sets the color of the thin line of the grid.
Public propertyStatic memberGridXAxisLineColor
Gets or sets the color of the X axis of the grid.
Public propertyStatic memberGridYAxisLineColor
Gets or sets the color of the Y axis of the grid.
Public propertyStatic memberGridZAxisLineColor
Gets or sets the color of the Z axis of the grid.
Public propertyStatic memberLanguageIdentifier
Gets or sets the language identifier.
Public propertyStatic memberLockedObjectColor
color used to draw locked objects.
Public propertyStatic memberMenuVisible
Gets or sets a value that determines if the File menu is visible.
Public propertyStatic memberPageviewPaperColor
Gets or sets the paper background. A rectangle is drawn into the background of page views to represent the printed area. The alpha portion of the color is used to draw the paper blended into the background
Public propertyStatic memberPreviousLanguageIdentifier
Gets or sets the previous language identifier.
Public propertyStatic memberSelectedObjectColor
The color used to draw selected objects. The default is yellow, but this can be customized by the user.
Public propertyStatic memberSelectionWindowCrossingFillColor
Color used to fill selection crossing window
Public propertyStatic memberSelectionWindowCrossingStrokeColor
Color used to draw stroke for selection crossing window
Public propertyStatic memberSelectionWindowFillColor
Color used to fill selection window
Public propertyStatic memberSelectionWindowStrokeColor
Color used to draw stroke for selection window
Public propertyStatic memberShowCrosshairs
Gets or sets a value that determines if cross hairs are visible.
Public propertyStatic memberShowFullPathInTitleBar
Gets or sets a value that determines if the full path of the document is shown in the Rhino title bar.
Public propertyStatic memberShowLayoutDropShadow
Display the drop shadow of layouts
Public propertyStatic memberShowOsnapBar
Shows or hides the object snap user interface.
Public propertyStatic memberShowSelectionFilterBar
Shows or hides the selection filter user interface.
Public propertyStatic memberShowSideBar
Shows or hides the side bar user interface.
Public propertyStatic memberShowStatusBar
Shows or hides the status bar user interface.
Public propertyStatic memberShowTitleBar
Shows or hides title bar.
Public propertyStatic memberShowViewportTitles
Shows or hides viewport titles.
Public propertyStatic memberTrackingColor
Gets or sets the tracking color.
Public propertyStatic memberUsePaintColors Obsolete.
Gets or sets a value indicating if logical paint colors should be used.
Public propertyStatic memberViewportBackgroundColor
Gets or sets the viewport background color.
Public propertyStatic memberViewportTabsVisibleAtStart
Display viewport tabs at start
Public propertyStatic memberWorldCoordIconXAxisColor
Gets or sets the color of the world coordinate X axis.
Public propertyStatic memberWorldCoordIconYAxisColor
Gets or sets the color of the world coordinate Y axis.
Public propertyStatic memberWorldCoordIconZAxisColor
Gets or sets the color of the world coordinate Z axis.
Top
Methods
  NameDescription
Public methodStatic memberDefaultPaintColor(PaintColor)
Get a default paint color for Rhino. The current paint color may be different than the default
Public methodStatic memberDefaultPaintColor(PaintColor, Boolean)
Get a default paint color for Rhino. The current paint color may be different than the default
Public methodStatic memberDefaultWidgetColor
Get a default widget color for Rhino. The current widget color may be different than the default
Public methodStatic memberGetCurrentState
Gets the current settings of the application.
Public methodStatic memberGetDefaultState
Gets the factory settings of the application.
Public methodStatic memberGetDefaultState(Boolean)
Gets the factory settings of the application.
Public methodStatic memberGetPaintColor(PaintColor)
Gets the color that is currently associated with a paint color.
Public methodStatic memberGetPaintColor(PaintColor, Boolean)
Gat a paint color. This overload provides a compute option for cases where colors are computed when they are "unset" colors.
Public methodStatic memberGetWidgetColor
Gets the .Net library color that is currently associated with a widget color.
Public methodStatic memberInitialMainWindowPosition
Location where the Main Rhino window attempts to show when the application is first started.
Public methodStatic memberRestoreDefaults
Commits the default settings as the current settings.
Public methodStatic memberSetPaintColor(PaintColor, Color)
Sets the logical paint color association to a specific .Net library color, without forced UI update.
Public methodStatic memberSetPaintColor(PaintColor, Color, Boolean)
Sets the logical paint color association to a specific .Net library color.
Public methodStatic memberSetToDarkMode
Set UI to the default dark mode color scheme
Public methodStatic memberSetToLightMode
Set UI to the default light mode color scheme
Public methodStatic memberSetWidgetColor(WidgetColor, Color)
Sets the logical widget color association to a specific .Net library color, without forced UI update.
Public methodStatic memberSetWidgetColor(WidgetColor, Color, Boolean)
Sets the logical widget color association to a specific .Net library color.
Public methodStatic memberUpdateFromState
Sets all settings to a particular defined joined state.
Public methodStatic memberUsingDefaultDarkModeColors
Determine if Rhino is running with default dark mode color settings
Public methodStatic memberUsingDefaultLightModeColors
Determine if Rhino is running with default light mode color settings
Top
See Also