AppearanceSettings Properties |
The AppearanceSettings type exposes the following members.
Name | Description | |
---|---|---|
CommandPromptBackgroundColor |
Gets or sets the color of the command prompt background.
| |
CommandPromptFontSize |
Size of font used in command prompt (in points)
| |
CommandPromptHypertextColor |
Gets or sets the color of the command prompt hypertext.
| |
CommandPromptPosition |
Gets or sets the command prompt position.
| |
CommandPromptTextColor |
Gets or sets the color of the command prompt text.
| |
CrosshairColor |
Gets or sets the color of the crosshair icon.
| |
CurrentLayerBackgroundColor |
Gets or sets the color used by the layer manager dialog as the background color for the current layer.
| |
DefaultFontFaceName |
Gets or sets the default font face name used in Rhino.
| |
DefaultLayerColor |
Gets or sets the default layer color.
| |
DefaultObjectColor |
Gets or sets the default color for new objects.
| |
DirectionArrowIconHeadSize |
length of direction arrowhead icon in pixels.
| |
DirectionArrowIconShaftSize |
length of direction arrow shaft icon in pixels.
| |
EchoCommandsToHistoryWindow | Gets or sets a value that determines if command names are written to the history window. | |
EchoPromptsToHistoryWindow | Gets or sets a value that determines if prompt messages are written to the history window. | |
EditCandidateColor |
Gets or sets the color of objects that are eligible to be edited.
| |
FeedbackColor |
Gets or sets the feedback color.
| |
FrameBackgroundColor |
Gets or sets the background color of the frame.
| |
GridThickLineColor |
Gets or sets the color of the thick line of the grid.
| |
GridThinLineColor |
Gets or sets the color of the thin line of the grid.
| |
GridXAxisLineColor |
Gets or sets the color of the X axis of the grid.
| |
GridYAxisLineColor |
Gets or sets the color of the Y axis of the grid.
| |
GridZAxisLineColor |
Gets or sets the color of the Z axis of the grid.
| |
LanguageIdentifier | Gets or sets the language identifier. | |
LockedObjectColor | color used to draw locked objects. | |
MenuVisible | Gets or sets a value that determines if the File menu is visible. | |
PageviewPaperColor |
Gets or sets the paper background. A rectangle is drawn into the background
of page views to represent the printed area. The alpha portion of the color
is used to draw the paper blended into the background
| |
PreviousLanguageIdentifier |
Gets or sets the previous language identifier.
| |
SelectedObjectColor |
The color used to draw selected objects.
The default is yellow, but this can be customized by the user.
| |
SelectionWindowCrossingFillColor |
Color used to fill selection crossing window
| |
SelectionWindowCrossingStrokeColor |
Color used to draw stroke for selection crossing window
| |
SelectionWindowFillColor |
Color used to fill selection window
| |
SelectionWindowStrokeColor |
Color used to draw stroke for selection window
| |
ShowCrosshairs | Gets or sets a value that determines if cross hairs are visible. | |
ShowFullPathInTitleBar | Gets or sets a value that determines if the full path of the document is shown in the Rhino title bar. | |
ShowLayoutDropShadow |
Display the drop shadow of layouts
| |
ShowOsnapBar |
Shows or hides the object snap user interface.
| |
ShowSelectionFilterBar |
Shows or hides the selection filter user interface.
| |
ShowSideBar |
Shows or hides the side bar user interface.
| |
ShowStatusBar |
Shows or hides the status bar user interface.
| |
ShowTitleBar |
Shows or hides title bar.
| |
ShowViewportTitles |
Shows or hides viewport titles.
| |
TrackingColor |
Gets or sets the tracking color.
| |
UsePaintColors | Obsolete.
Gets or sets a value indicating if logical paint colors should be used.
| |
ViewportBackgroundColor |
Gets or sets the viewport background color.
| |
ViewportTabsVisibleAtStart |
Display viewport tabs at start
| |
WorldCoordIconXAxisColor |
Gets or sets the color of the world coordinate X axis.
| |
WorldCoordIconYAxisColor |
Gets or sets the color of the world coordinate Y axis.
| |
WorldCoordIconZAxisColor |
Gets or sets the color of the world coordinate Z axis.
|