Click or drag to resize

AppearanceSettings Methods

The AppearanceSettings type exposes the following members.

Methods
  NameDescription
Public methodStatic memberDefaultPaintColor(PaintColor)
Get a default paint color for Rhino. The current paint color may be different than the default
Public methodStatic memberDefaultPaintColor(PaintColor, Boolean)
Get a default paint color for Rhino. The current paint color may be different than the default
Public methodStatic memberDefaultWidgetColor
Get a default widget color for Rhino. The current widget color may be different than the default
Public methodStatic memberGetCurrentState
Gets the current settings of the application.
Public methodStatic memberGetDefaultState
Gets the factory settings of the application.
Public methodStatic memberGetDefaultState(Boolean)
Gets the factory settings of the application.
Public methodStatic memberGetPaintColor(PaintColor)
Gets the color that is currently associated with a paint color.
Public methodStatic memberGetPaintColor(PaintColor, Boolean)
Gat a paint color. This overload provides a compute option for cases where colors are computed when they are "unset" colors.
Public methodStatic memberGetWidgetColor
Gets the .Net library color that is currently associated with a widget color.
Public methodStatic memberInitialMainWindowPosition
Location where the Main Rhino window attempts to show when the application is first started.
Public methodStatic memberRestoreDefaults
Commits the default settings as the current settings.
Public methodStatic memberSetPaintColor(PaintColor, Color)
Sets the logical paint color association to a specific .Net library color, without forced UI update.
Public methodStatic memberSetPaintColor(PaintColor, Color, Boolean)
Sets the logical paint color association to a specific .Net library color.
Public methodStatic memberSetToDarkMode
Set UI to the default dark mode color scheme
Public methodStatic memberSetToLightMode
Set UI to the default light mode color scheme
Public methodStatic memberSetWidgetColor(WidgetColor, Color)
Sets the logical widget color association to a specific .Net library color, without forced UI update.
Public methodStatic memberSetWidgetColor(WidgetColor, Color, Boolean)
Sets the logical widget color association to a specific .Net library color.
Public methodStatic memberUpdateFromState
Sets all settings to a particular defined joined state.
Public methodStatic memberUsingDefaultDarkModeColors
Determine if Rhino is running with default dark mode color settings
Public methodStatic memberUsingDefaultLightModeColors
Determine if Rhino is running with default light mode color settings
Top
See Also