Click or drag to resize

CursorTooltipSettingsState Class

Represents a snapshot of CursorTooltipSettings.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsCursorTooltipSettingsState

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class CursorTooltipSettingsState

The CursorTooltipSettingsState type exposes the following members.

Constructors
  NameDescription
Public methodCursorTooltipSettingsState
Initializes a new instance of the CursorTooltipSettingsState class
Top
Properties
  NameDescription
Public propertyAutoSuppress
Attempts to display only the most useful tooltip.
Public propertyBackgroundColor
Tooltip background color.
Public propertyCommandPromptPane
Displays the current command prompt.
Public propertyDistancePane
Displays the distance from the last picked point.
Public propertyEnableGumballToolTips
Turns on/off gumball tooltips
Public propertyOffset
The x and y distances in pixels from the cursor location to the tooltip.
Public propertyOsnapPane
Displays the current object snap selection.
Public propertyPointPane
Displays the current construction plane coordinates.
Public propertyRelativePointPane
Displays the relative construction plane coordinates and angle from the last picked point.
Public propertyTextColor
Tooltip text color.
Public propertyTooltipsEnabled
Turns on/off cursor tooltips.
Top
Methods
  NameDescription
Top
See Also