Click or drag to resize

ModelAidSettings Class

Contains static methods and properties to modify model aid settings.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsModelAidSettings

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class ModelAidSettings

The ModelAidSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAltPlusArrow
true means Alt+arrow is used for nudging.
Public propertyStatic memberAutoAlignCPlane
Gets or sets whether the cplane will automatically align to the selection
Public propertyStatic memberAutoCPlaneAlignment
//0 = object, 1 = world, 2 = view
Public propertyStatic memberAutoGumballEnabled
When AutoGumball is on, a gumball automatically appears when objects are pre-picked.
Public propertyStatic memberControlPolygonDisplayDensity
Gets or sets the control polygon display density.
Public propertyStatic memberCtrlNudgeKeyStep
Gets or sets the Ctrl-key based nudge step amount.
Public propertyStatic memberDisplayControlPolygon
Gets or sets the enabled state of Rhino's display control polygon.
Public propertyStatic memberExtendToApparentIntersection
Gets or sets the enabled state of Rhino's extend to apparent intersections.
Public propertyStatic memberExtendTrimLines
Gets or sets the enabled state of Rhino's extend trim lines.
Public propertyStatic memberGridSnap
Gets or sets the enabled state of Rhino's grid snap modeling aid.
Public propertyStatic memberGumballAutoReset
When GumballAutoReset is on the gumball resets its orientation after a drag When GumballAutoReset is off the gumball orientation is kept to where it was dragged
Public propertyStatic memberGumballExtrudeMergeFaces
When ExtrudeMergeFaces is true the gumball will attempt to merge faces if possible after extruding a face
Public propertyStatic memberHighlightControlPolygon
Gets or sets the enabled state of Rhino's highlight dialog modeling aid.
Public propertyStatic memberMousePickboxRadius
radius of mouse pick box in pixels.
Public propertyStatic memberNudgeKeyStep
Gets or sets the nudge step amount.
Public propertyStatic memberNudgeMode
0 = world, 1 = cplane, 2 = view, 3 = UVN, -1 = not set.
Public propertyStatic memberOnlySnapToSelected
Public propertyStatic memberOrientAutoCPlaneToView
Gets or sets whether the auto cplane will rotate towards the view after aligning to the selection
Public propertyStatic memberCode exampleOrtho
Gets or sets the enabled state of Rhino's ortho modeling aid.
Public propertyStatic memberOrthoAngle
Gets or sets the base orthogonal angle.
Public propertyStatic memberOrthoUseZ
Gets or sets whether Ortho will snap to the CPlane Z axis
Public propertyStatic memberOsnap
Enables or disables Rhino's object snap modeling aid.
Public propertyStatic memberOsnapCursorMode
Gets or sets the OSnap cursor mode.
Public propertyStatic memberOsnapModes
Returns or sets Rhino's current object snap mode. The mode is a bitwise value based on the OsnapModes enumeration.
Public propertyStatic memberOsnapPickboxRadius
Enables or disables Rhino's planar modeling aid.
Public propertyStatic memberPlanar
Gets or sets the enabled state of Rhino's Planar modeling aid.
Public propertyStatic memberPointDisplay
Gets or sets the point display mode.
Public propertyStatic memberProjectSnapToCPlane
Gets or sets the enabled state of Rhino's Project modeling aid.
Public propertyStatic memberShiftNudgeKeyStep
Gets or sets the Shift-key based nudge step amount.
Public propertyStatic memberSnappyGumballEnabled
When SnappyGumball is on, a dragging a gumball moves the center point. When snappy gumball is off, dragging a gumball moves the mouse down point.
Public propertyStatic memberSnapToFiltered
Public propertyStatic memberSnapToLocked
Gets or sets the locked state of the snap modeling aid.
Public propertyStatic memberSnapToOccluded
Public propertyStatic memberStickyAutoCPlane
Gets or set whether the auto cplane will stay even after deselection
Public propertyStatic memberUniversalConstructionPlaneMode
Gets or sets the locked state of the snap modeling aid.
Public propertyStatic memberUseHorizontalDialog
Gets or sets the enabled state of Rhino's use horizontal dialog modeling aid.
Top
Methods
  NameDescription
Public methodStatic memberGetCurrentState
Gets the current settings.
Public methodStatic memberGetDefaultState
Gets the factory settings.
Public methodStatic memberUpdateFromState
Updates from a particular setting state.
Top
See Also