Click or drag to resize

ModelAidSettingsState Class

Represents a snapshot of ModelAidSettings.
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsModelAidSettingsState

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ModelAidSettingsState

The ModelAidSettingsState type exposes the following members.

Properties
  NameDescription
Public propertyAltPlusArrow
true mean Alt+arrow is used for nudging.
Public propertyAutoAlignCPlane
Public propertyAutoCPlaneAlignment
//0 = object, 1 = world, 2 = view
Public propertyControlPolygonDisplayDensity
Gets or sets the control polygon display density.
Public propertyCtrlNudgeKeyStep
Gets or sets the Ctrl-key based nudge step amount.
Public propertyDisplayControlPolygon
Gets or sets the enabled state of Rhino's display control polygon.
Public propertyExtendToApparentIntersection
Gets or sets the enabled state of Rhino's extend to apparent intersections.
Public propertyExtendTrimLines
Gets or sets the enabled state of Rhino's extend trim lines.
Public propertyGridSnap
Gets or sets the enabled state of Rhino's grid snap modeling aid.
Public propertyHighlightControlPolygon
Gets or sets the enabled state of Rhino's highlight dialog modeling aid.
Public propertyMousePickboxRadius
Gets or sets the radius of the mouse pick box in pixels.
Public propertyNudgeKeyStep
Gets or sets the nudge step amount.
Public propertyNudgeMode
0 = world, 1 = cplane, 2 = view, 3 = UVN, -1 = not set.
Public propertyOrientAutoCPlaneToView
Gets or sets whether the auto cplane will rotate towards the view after aligning to the selection
Public propertyOrtho
Gets or sets the enabled state of Rhino's ortho modeling aid.
Public propertyOrthoAngle
Gets or sets the base orthogonal angle.
Public propertyOrthoUseZ
Gets or sets whether Ortho will snap to the CPlane Z axis
Public propertyOsnap
Gets or sets the enabled state of Rhino's object snap modeling aid.
Public propertyOsnapCursorMode
Gets or sets the OSnap cursor mode.
Public propertyOsnapModes
Returns or sets Rhino's current object snap mode.

The mode is a bitwise value based on the OsnapModes enumeration.

Public propertyOsnapPickboxRadius
Enables or disables Rhino's planar modeling aid.
Public propertyPlanar
Gets or sets the enabled state of Rhino's Planar modeling aid.
Public propertyPointDisplay
Gets or sets the point display mode.
Public propertyProjectSnapToCPlane
Gets or sets the enabled state of Rhino's Project modeling aid.
Public propertyShiftNudgeKeyStep
Gets or sets the Shift-key based nudge step amount.
Public propertySnapToLocked
Gets or sets the locked state of the snap modeling aid.
Public propertyStickyAutoCPlane
Gets or set whether the auto cplane will stay even after deselection
Public propertyUniversalConstructionPlaneMode
Gets or sets the locked state of the snap modeling aid.
Public propertyUseHorizontalDialog
Gets or sets the enabled state of Rhino's use horizontal dialog modeling aid.
Top
Methods
  NameDescription
Top
See Also