Click or drag to resize

AppearanceSettingsState Class

snapshot of the values in AppearanceSettings
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsAppearanceSettingsState

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class AppearanceSettingsState

The AppearanceSettingsState type exposes the following members.

Properties
  NameDescription
Public propertyCommandPromptBackgroundColor
Gets or sets the command prompt background color.
Public propertyCommandPromptFontName
Name of the font used in the command prompt
Public propertyCommandPromptFontSize
Size of the font used in the command prompt (in points)
Public propertyCommandPromptHypertextColor
Gets or sets the command prompt hypertext color.
Public propertyCommandPromptTextColor
Gets or sets the command prompt text color.
Public propertyCrosshairColor
Gets or sets the crosshair color.
Public propertyCurrentLayerBackgroundColor
Gets or sets the color used by the layer manager dialog as the background color for the current layer.
Public propertyDefaultFontFaceName
Gets or sets the name of the default font face.
Public propertyDefaultLayerColor
Gets or sets the default layer color.
Public propertyDefaultObjectColor
Gets or sets the default object color.
Public propertyDirectionArrowIconHeadSize
Set the arrow icon head size.
Public propertyDirectionArrowIconShaftSize
Set the arrow icon shaft size.
Public propertyEchoCommandsToHistoryWindow
Gets or sets a value that determines if command names are written to the history window.
Public propertyEchoPromptsToHistoryWindow
Gets or sets a value that determines if prompt messages are written to the history window.
Public propertyEditCandidateColor
Gets or sets the color of objects that are eligible to be edited.
Public propertyFeedbackColor
Gets or sets the feedback color.
Public propertyFrameBackgroundColor
Gets or sets the frame background color.
Public propertyGridThickLineColor
Gets or sets the color of the thick line in the grid.
Public propertyGridThinLineColor
Gets or sets the color of the thin line in the grid.
Public propertyGridXAxisLineColor
Gets or sets the color of X axis line in the grid.
Public propertyGridYAxisLineColor
Gets or sets the color of Y axis line in the grid.
Public propertyGridZAxisLineColor
Gets or sets the color of Z axis line in the grid.
Public propertyLockedObjectColor
Gets or sets the color used to draw locked objects.
Public propertyMenuVisible
Get/Set menu visibility
Public propertyPageviewPaperColor
CRhinoPageView paper background. A rectangle is drawn into the background of page views to represent the printed area. The alpha portion of the color is used to draw the paper blended into the background
Public propertySelectedObjectColor
The color used to draw selected objects. The default is yellow, but this can be customized by the user.
Public propertySelectionWindowCrossingFillColor
Gets or sets the color used to fill a crossing selection window
Public propertySelectionWindowCrossingStrokeColor
Gets or sets the color used to draw the stroke of a crossing selection window
Public propertySelectionWindowFillColor
Gets or sets the color used to fill a selection window
Public propertySelectionWindowStrokeColor
Gets or sets the color used to draw the stroke of a selection window
Public propertyShowCrosshairs
Gets or sets a value that determines if cross hairs are visible.
Public propertyShowFullPathInTitleBar
Gets or sets a value that determines if the full path of the document is shown in the Rhino title bar.
Public propertyShowLayoutDropShadow
Display the drop shadow of layouts
Public propertyShowStatusBar
Get/Set status bar visibility
Public propertyShowTitleBar
Shows or hides title bar.
Public propertyShowViewportTitles
Get/Set viewport title visibility
Public propertyTrackingColor
Gets or sets the tracking color.
Public propertyViewportBackgroundColor
Gets or sets the viewport background color.
Public propertyViewportTabsVisibleAtStart
Display viewport tabs at start
Public propertyWorldCoordIconXAxisColor
Gets or sets the color of the world X axis of the world coordinates icon, appearing usually bottom left in viewports.
Public propertyWorldCoordIconYAxisColor
Gets or sets the color of the world Y axis of the world coordinate icon, appearing usually bottom left in viewports.
Public propertyWorldCoordIconZAxisColor
Gets or sets the color of the world Z axis of the world coordinate icon, appearing usually bottom left in viewports.
Top
Methods
  NameDescription
Top
See Also