Click or drag to resize

KeyboardShortcut Class

A shortcut is a key plus modifier combination that executes a macro
Inheritance Hierarchy
SystemObject
  Rhino.ApplicationSettingsKeyboardShortcut

Namespace:  Rhino.ApplicationSettings
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class KeyboardShortcut

The KeyboardShortcut type exposes the following members.

Constructors
  NameDescription
Public methodKeyboardShortcut
Initializes a new instance of the KeyboardShortcut class
Top
Properties
  NameDescription
Public propertyKey
Key used for shortcut
Public propertyMacro
Macro to execute when key plus modifier are pressed
Public propertyModifier
Modifier key used for shortcut
Top
Methods
  NameDescription
Top
See Also