Grasshopper API
Grasshopper API
Grasshopper.Kernel
GH_ActiveObject Class
GH_Alias Class
GH_Arrange Enumeration
GH_AssemblyFolderInfo Structure
GH_AssemblyInfo Class
GH_AssemblyInfoStub Class
GH_AssemblyPriority Class
GH_Attributes(T) Class
GH_AttributesChangedEventArgs Class
GH_Author Class
GH_AutoSaveSettings Class
GH_AutoSaveSettings.AutoSaveFileFormatChangedEventHandler Delegate
GH_AutoSaveSettings.EnableAutoSaveChangedEventHandler Delegate
GH_AutoSaveSettings.SaveOnDataFlatteningChangedEventHandler Delegate
GH_AutoSaveSettings.SaveOnDocumentUnloadChangedEventHandler Delegate
GH_AutoSaveSettings.SaveOnObjectAddedChangedEventHandler Delegate
GH_AutoSaveSettings.SaveOnObjectChangeChangedEventHandler Delegate
GH_AutoSaveSettings.SaveOnObjectRemovedChangedEventHandler Delegate
GH_AutoSaveSettings.SaveOnWireEventChangedEventHandler Delegate
GH_AutoSaveTrigger Enumeration
GH_BakeUtility Class
GH_BitmapChannel Enumeration
GH_CharPatternParamNameConstructor Class
GH_ClipboardType Enumeration
GH_Component Class
GH_Component.GH_InputParamManager Class
GH_Component.GH_OutputParamManager Class
GH_ComponentPaletteStyle Enumeration
GH_ComponentParamServer Class
GH_ComponentParamServer.IGH_SyncObject Interface
GH_ComponentParamServer.NullParamAttributes Class
GH_ComponentParamServer.ParameterChangedEventHandler Delegate
GH_ComponentParamServer.ParameterNickNameChangedEventHandler Delegate
GH_ComponentParamServer.ParameterSourcesChangedEventHandler Delegate
GH_ComponentServer Class
GH_ComponentServer.GHAFileLoadedEventHandler Delegate
GH_ConnectivityDiagram Class
GH_ConnectivityDisparity Class
GH_ConnectivityNode Class
GH_Conversion Enumeration
GH_Convert Class
GH_CustomEventServer Class
GH_DataComparison Enumeration
GH_DataMapping Enumeration
GH_DebugDescriptionWriter Class
GH_DisplayExpiredEventArgs Class
GH_DocContextEventArgs Class
GH_DocEnabledEventArgs Class
GH_DocFilePathEventArgs Class
GH_DocModifiedEventArgs Class
GH_DocObjectEventArgs Class
GH_DocSettingsEventArgs Class
GH_Document Class
GH_Document.ContextChangedEventHandler Delegate
GH_Document.DefaultPreviewColourChangedEventHandler Delegate
GH_Document.DefaultSelectedPreviewColourChangedEventHandler Delegate
GH_Document.EnabledChangedEventHandler Delegate
GH_Document.EnableSolutionsChangedEventHandler Delegate
GH_Document.FilePathChangedEventHandler Delegate
GH_Document.GH_ActiveObjectFilter Delegate
GH_Document.GH_ScheduleDelegate Delegate
GH_Document.ModifiedChangedEventHandler Delegate
GH_Document.ObjectsAddedEventHandler Delegate
GH_Document.ObjectsDeletedEventHandler Delegate
GH_Document.SettingsChangedEventHandler Delegate
GH_Document.SolutionEndEventHandler Delegate
GH_Document.SolutionStartEventHandler Delegate
GH_Document.UndoStateChangedEventHandler Delegate
GH_DocumentAssociations Class
GH_DocumentContext Enumeration
GH_DocumentEventServer Class
GH_DocumentIO Class
GH_DocumentObject Class
GH_DocumentObject.ColourEventHandler Delegate
GH_DocumentRank Enumeration
GH_DocumentServer Class
GH_DocumentServer.DocumentAddedEventHandler Delegate
GH_DocumentServer.DocumentRemovedEventHandler Delegate
GH_DocumentSettings Enumeration
GH_DocumentTree Class
GH_DocumentTreeNode Class
GH_DocUndoEventArgs Class
GH_Exposure Enumeration
GH_ExternalFile Class
GH_ExternalFileType Enumeration
GH_FileSystemEventServer Class
GH_FileSystemEventServer.FileEvent Delegate
GH_FileWatcher Class
GH_FileWatcher.FileChanged Delegate
GH_FileWatcher.FileChangedSimple Delegate
GH_FileWatcherEvents Enumeration
GH_Filter Enumeration
GH_FontServer Class
GH_FontServer.ConsoleFamilyChangedEventHandler Delegate
GH_FontServer.ScriptFamilyChangedEventHandler Delegate
GH_FontServer.StandardFamilyChangedEventHandler Delegate
GH_Format Class
GH_GetterResult Enumeration
GH_GHALoadingEventArgs Class
GH_GHXHarvester Class
GH_GuidConflictSolution Enumeration
GH_IconDisplayMode Enumeration
GH_InstanceDescription Class
GH_LibraryLicense Enumeration
GH_LineParser Class
GH_LineParserAction Enumeration
GH_ListUtil Class
GH_LoadingAttribute Class
GH_LoadingDemand Enumeration
GH_LoadingInstruction Enumeration
GH_LoadingMechanism Enumeration
GH_MatchLevel Enumeration
GH_MatchWeight Enumeration
GH_MemoryBitmap Class
GH_ObjectChangedEventArgs Class
GH_ObjectEventType Enumeration
GH_ObjectSpecies Enumeration
GH_ObjectType Enumeration
GH_Param(T) Class
GH_ParamAccess Enumeration
GH_ParamData Enumeration
GH_ParameterContext Class
GH_ParameterSide Enumeration
GH_ParamHashFields Enumeration
GH_ParamKind Enumeration
GH_ParamServerEventArgs Class
GH_ParamWireDisplay Enumeration
GH_PatternMatching Class
GH_PatternMatching.MatchingMode Enumeration
GH_PersistentGeometryParam(T) Class
GH_PersistentParam(T) Class
GH_PersistentReferenceParam(T) Class
GH_PickBox Enumeration
GH_PingDocumentEventArgs Class
GH_PluginFolderType Enumeration
GH_PreviewArgs Class
GH_PreviewBoundary Class
GH_PreviewExpiredEventArgs Class
GH_PreviewFilter Enumeration
GH_PreviewMesh Enumeration
GH_PreviewMeshArgs Class
GH_PreviewMode Enumeration
GH_PreviewUtil Class
GH_PreviewWireArgs Class
GH_PrincipalState Enumeration
GH_ProcessStep Enumeration
GH_ProfilerMode Enumeration
GH_RelevantObjectData Class
GH_RelevantObjectFilter Enumeration
GH_RenderArgs Class
GH_RuntimeMessage Class
GH_RuntimeMessageLevel Enumeration
GH_SelectionState Enumeration
GH_SelectionTopology Enumeration
GH_SettingsServer Class
GH_SettingsType Enumeration
GH_SolutionEventArgs Class
GH_SolutionExpiredEventArgs Class
GH_SolutionMode Enumeration
GH_SolutionPhase Enumeration
GH_SolutionSpan Structure
GH_State Class
GH_StateServer Class
GH_StateTag Class
GH_StateTag.DrawCallback Delegate
GH_StateTagLayoutDirection Enumeration
GH_StateTagList Class
GH_TaskCapableComponent(T) Class
GH_TimeKind Enumeration
GH_TypeLib Class
GH_UndoOperation Enumeration
GH_UpgradeUtil Class
GH_UserObject Class
GH_ValueProxy(T) Class
GH_ZuiAction Class
IGH_ActiveObject Interface
IGH_Attributes Interface
IGH_Author Interface
IGH_BakeAwareData Interface
IGH_BakeAwareObject Interface
IGH_Component Interface
IGH_ContextualComponent Interface
IGH_ContextualParameter Interface
IGH_ContextualParameter2 Interface
IGH_DataAccess Interface
IGH_DebugDescription Interface
IGH_DocumentObject Interface
IGH_DocumentObject.AttributesChangedEventHandler Delegate
IGH_DocumentObject.DisplayExpiredEventHandler Delegate
IGH_DocumentObject.ObjectChangedEventHandler Delegate
IGH_DocumentObject.PingDocumentEventHandler Delegate
IGH_DocumentObject.PreviewExpiredEventHandler Delegate
IGH_DocumentObject.SolutionExpiredEventHandler Delegate
IGH_DocumentOwner Interface
IGH_EventConsumer Interface
IGH_InitCodeAware Interface
IGH_InstanceDescription Interface
IGH_InstanceGuidDependent Interface
IGH_ObjectProxy Interface
IGH_Param Interface
IGH_PreviewArgs Interface
IGH_PreviewData Interface
IGH_PreviewMeshData Interface
IGH_PreviewObject Interface
IGH_RenderAwareData Interface
IGH_StateAwareObject Interface
IGH_StateTag Interface
IGH_TaskCapableComponent Interface
IGH_UpgradeObject Interface
IGH_UserPromptAware Interface
IGH_ValueProxy Interface
IGH_VariableParameterComponent Interface
IGH_ZuiAction Interface
IRcpAwareObject Interface
GH_PickBox Enumeration
Represents the different ways in which picking rectangles can behave.
Namespace:
Grasshopper.Kernel
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax
C#
VB
Copy
public
enum
GH_PickBox
Public
Enumeration
GH_PickBox
Members
Member name
Value
Description
Window
0
The picking box must completely surround the object box.
Crossing
1
The picking box must only partially intersect the object box.
See Also
Reference
Grasshopper.Kernel Namespace
Grasshopper for Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com