IGH_ContextualParameter Interface |
Namespace: Grasshopper.Kernel
The IGH_ContextualParameter type exposes the following members.
Name | Description | |
---|---|---|
AtLeast |
Minimum number of inputs to request
| |
AtMost |
Maximum number of inputs to request.
| |
ContextualData |
Iterate over all specified contextual values.
| |
Immediate |
Gets whether this parameter triggers immediate updates from inside
its getter. Immediacy is important for a smooth experience,
but it maybe disabled if the expected recalculation time becomes
excessive.
| |
Prompt |
Gets the prompt to be displayed while asking the user to enter data.
The prompt string may contain '{0}' fields which will be populated with
the amount of values picked so far.
|
Name | Description | |
---|---|---|
AssignContextualData |
Assign a collection of values as contextual data.
| |
AutoAssignContextualData |
Use the in-build getter UI to assign data to the parameter.
|