Click or drag to resize

GH_RenderArgs Class

This class is passed to objects that implement IGH_RenderAwareData or IGH_RenderAwareObject during render queue operations.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_RenderArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_RenderArgs

The GH_RenderArgs type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyDocument
Gets the rhino document from whence the render originated.
Public propertyMaterialNormal Obsolete.
Gets the material hint to use for unselected objects.
Public propertyMaterialSelected Obsolete.
Gets the material hint to use for selected objects.
Public propertyModelTransform
Gets the current model transform.
Public propertyPluginId
Gets the render plugin id that is about to render this geometry.
Public propertyViewport
Gets the viewport details involved in this rendering.
Public propertyViewportName
Gets the viewport name involved in this rendering.
Top
Methods
See Also