GH_ParamKind Enumeration |
Namespace: Grasshopper.Kernel
Member name | Value | Description | |
---|---|---|---|
unknown | 0 | Unknown, when this happens, something went wrong. Most likely it is due to someone deriving from GH_Param and not setting the kind. | |
floating | 1 | Parameter is top-level. | |
input | 2 | Parameter is tied to an owner component as an input. | |
output | 3 | Parameter is tied to an owner component as an output. |