IGH_DocumentObject Interface |
Namespace: Grasshopper.Kernel
The IGH_DocumentObject type exposes the following members.
Name | Description | |
---|---|---|
Attributes |
Gets or sets the attributes that are associated with this object.
Only set custom attributes if you know what you are doing.
| |
Category |
Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.
(Inherited from IGH_InstanceDescription.) | |
ComponentGuid |
Returns a consistent ID for this object type. Every object must supply a unique and unchanging
ID that is used to identify objects of the same type.
| |
Description |
Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.
(Inherited from IGH_InstanceDescription.) | |
Exposure |
Gets the exposure of this object in the Graphical User Interface.
| |
HasCategory |
Gets whether or not the Category field has been set.
(Inherited from IGH_InstanceDescription.) | |
HasSubCategory |
Gets whether or not the SubCategory field has been set.
(Inherited from IGH_InstanceDescription.) | |
Icon_24x24 |
The icon associated with this object.
| |
Icon_24x24_Locked |
The greyscale icon of this object.
| |
IconDisplayMode |
Gets the current display mode of the object.
| |
InstanceDescription |
Gets a description of the current state of the object.
This field is usually the same as the Description() field, but it might be variable when overridden.
(Inherited from IGH_InstanceDescription.) | |
InstanceGuid |
Gets the ID of this runtime instance.
(Inherited from IGH_InstanceDescription.) | |
Keywords |
Gets a list of additional keywords that describe the object. Typically this list is empty but you
can override this property to aid in object searches.
(Inherited from IGH_InstanceDescription.) | |
Name |
Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.
(Inherited from IGH_InstanceDescription.) | |
NickName |
Gets or sets the nickname of the object. This field can be changed by the user.
(Inherited from IGH_InstanceDescription.) | |
Obsolete |
Gets whether this object is Obsolete.
| |
SubCategory |
Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.
(Inherited from IGH_InstanceDescription.) |
Name | Description | |
---|---|---|
AddedToDocument |
This method will be called when an object is added to a document.
| |
AppendMenuItems |
This function is called when a context menu is about to be displayed.
Override it to set custom items.
| |
CreateAttributes |
Create new default attributes for this object. You should only call this function
when the Attributes() field is null.
| |
DocumentContextChanged |
This method will be called when the document that owns this object moves into a different context.
| |
ExpirePreview |
Call this function when you suspect that the preview has expired for this object.
This will cause the display cache to be eradicated.
| |
ExpireSolution |
Call this function whenever you do something which expires the current solution.
This will make sure all caches are erased, all downstream objects are expired and that
the event is raised.
The default implementation merely places a call to OnSolutionExpired(), override this function
in derived classes to make sure you clear local data caches and expire downstream objects.
| |
IsolateObject |
Destroy all connections to other objects.
| |
MovedBetweenDocuments |
This method will be called when an object is moved from one document to another.
| |
NewInstanceGuid |
Generate a new random instance GUID
(Inherited from IGH_InstanceDescription.) | |
NewInstanceGuid(Guid) |
Set the instance ID to be a specific GUID. This is very dangerous, only use this function
if you're 6"4' and called David.
(Inherited from IGH_InstanceDescription.) | |
OnAttributesChanged |
Raises the AttributesChanged event on the toplevel object.
| |
OnDisplayExpired |
Raises the DisplayExpired event on the toplevel object.
| |
OnObjectChanged(GH_ObjectChangedEventArgs) |
Raises the ObjectChanged event on the current (!not the top level!) object.
| |
OnObjectChanged(GH_ObjectEventType) |
Raises the ObjectChanged event on the current (!not the top level!) object.
| |
OnObjectChanged(String) |
Raises the ObjectChanged event on the current (!not the top level!) object.
| |
OnObjectChanged(GH_ObjectEventType, Object) |
Raises the ObjectChanged event on the current (!not the top level!) object.
| |
OnObjectChanged(String, Object) |
Raises the ObjectChanged event on the current (!not the top level!) object.
| |
OnPingDocument |
Raise the PingDocument Event on the toplevel object and try to find
the document which owns this object.
| |
OnPreviewExpired |
Raises the PreviewExpired event on the toplevel object.
| |
OnSolutionExpired |
Raises the SolutionExpired event on the toplevel object.
| |
RecordUndoEvent(GH_UndoRecord) |
Record an entire undo record.
| |
RecordUndoEvent(String) |
Record a generic object change undo event.
| |
RecordUndoEvent(String, IGH_UndoAction) |
Record a specific object change undo event.
| |
RemovedFromDocument |
This method will be called when an object is removed from a document.
| |
TriggerAutoSave |
Triggers the AutoSave function on the owner document with the object_changed flag.
| |
TriggerAutoSave(GH_AutoSaveTrigger) |
Triggers the AutoSave function on the owner document with a custom flag.
| |
TriggerAutoSave(Guid) |
Triggers the AutoSave function on the owner document with the object_changed flag.
| |
TriggerAutoSave(GH_AutoSaveTrigger, Guid) |
Triggers the AutoSave function on the owner document with a custom flag.
|
Name | Description | |
---|---|---|
AttributesChanged |
Raised whenever the number or kind of attributes changes. This event is handled
by GH_Documents who subsequently wipe their attribute caches.
| |
DisplayExpired |
Raised whenever the display (on the Canvas) of a certain object becomes invalid.
| |
ObjectChanged |
Raised whenever some property of the object changes that would affect remote instances.
| |
PingDocument |
Raised whenever an object needs to know which GH_Document it belongs to.
| |
PreviewExpired |
Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid.
| |
SolutionExpired |
Raised whenever the solution of a certain object becomes invalid.
|