IGH_InstanceDescription Interface |
Namespace: Grasshopper.Kernel
The IGH_InstanceDescription type exposes the following members.
Name | Description | |
---|---|---|
Category |
Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.
| |
Description |
Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.
| |
HasCategory |
Gets whether or not the Category field has been set.
| |
HasSubCategory |
Gets whether or not the SubCategory field has been set.
| |
InstanceDescription |
Gets a description of the current state of the object.
This field is usually the same as the Description() field, but it might be variable when overridden.
| |
InstanceGuid |
Gets the ID of this runtime instance.
| |
Keywords |
Gets a list of additional keywords that describe the object. Typically this list is empty but you
can override this property to aid in object searches.
| |
Name |
Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.
| |
NickName |
Gets or sets the nickname of the object. This field can be changed by the user.
| |
SubCategory |
Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.
|
Name | Description | |
---|---|---|
NewInstanceGuid |
Generate a new random instance GUID
| |
NewInstanceGuid(Guid) |
Set the instance ID to be a specific GUID. This is very dangerous, only use this function
if you're 6"4' and called David.
| |
Read |
This method is called whenever the instance is required to deserialize itself.
(Inherited from GH_ISerializable.) | |
Write |
This method is called whenever the instance is required to serialize itself.
(Inherited from GH_ISerializable.) |