IGH_DocumentObject Properties |
The IGH_DocumentObject type exposes the following members.
Name | Description | |
---|---|---|
![]() | Attributes |
Gets or sets the attributes that are associated with this object.
Only set custom attributes if you know what you are doing.
|
![]() | Category |
Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.
(Inherited from IGH_InstanceDescription.) |
![]() | ComponentGuid |
Returns a consistent ID for this object type. Every object must supply a unique and unchanging
ID that is used to identify objects of the same type.
|
![]() | Description |
Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.
(Inherited from IGH_InstanceDescription.) |
![]() | Exposure |
Gets the exposure of this object in the Graphical User Interface.
|
![]() | HasCategory |
Gets whether or not the Category field has been set.
(Inherited from IGH_InstanceDescription.) |
![]() | HasSubCategory |
Gets whether or not the SubCategory field has been set.
(Inherited from IGH_InstanceDescription.) |
![]() | Icon_24x24 |
The icon associated with this object.
|
![]() | Icon_24x24_Locked |
The greyscale icon of this object.
|
![]() | IconDisplayMode |
Gets the current display mode of the object.
|
![]() | InstanceDescription |
Gets a description of the current state of the object.
This field is usually the same as the Description() field, but it might be variable when overridden.
(Inherited from IGH_InstanceDescription.) |
![]() | InstanceGuid |
Gets the ID of this runtime instance.
(Inherited from IGH_InstanceDescription.) |
![]() | Keywords |
Gets a list of additional keywords that describe the object. Typically this list is empty but you
can override this property to aid in object searches.
(Inherited from IGH_InstanceDescription.) |
![]() | Name |
Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.
(Inherited from IGH_InstanceDescription.) |
![]() | NickName |
Gets or sets the nickname of the object. This field can be changed by the user.
(Inherited from IGH_InstanceDescription.) |
![]() | Obsolete |
Gets whether this object is Obsolete.
|
![]() | SubCategory |
Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.
(Inherited from IGH_InstanceDescription.) |