GH_State Class |
Namespace: Grasshopper.Kernel
The GH_State type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_State | Initializes a new instance of the GH_State class |
![]() | GH_State(GH_State) | Initializes a new instance of the GH_State class |
Name | Description | |
---|---|---|
![]() | DataGuid |
Gets the state data stored under the specified ID
|
![]() | DataInt32 |
Gets the state data stored under the specified index
|
![]() | LastModified |
Gets the date at which this state was last modified.
|
![]() | Name |
Gets or sets the name of this state.
|
![]() | StateCount |
Gets the number of items stored in the state database.
|
![]() | StateData |
Gets a pointer to the internal database of states.
|
Name | Description | |
---|---|---|
![]() | AddStateObject |
Append a new object to the database.
|
![]() | ClearStates |
Removes all items from the state database.
|
![]() | CreateStateFromDocument |
Creates a state database from a document.
|
![]() | Read | |
![]() | RemoveStateObject |
Remove an object from the database.
|
![]() | Write |