GH_ValueProxyT Class |
Namespace: Grasshopper.Kernel
The GH_ValueProxyT type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_ValueProxyT |
Default constructor for the base class. All derived classes must call this constructor.
|
Name | Description | |
---|---|---|
![]() | Duplicate | |
![]() | Duplicate_T | |
![]() | FromString |
Performs the String->Value parsing. The default implementation always returns False.
|
![]() | MutateString | |
![]() | ToString |
Performs a default ToString operation on the local value.
If the value is Nothing, an empty String is returned.
(Overrides ObjectToString.) |
Name | Description | |
---|---|---|
![]() | m_IsStringProxy | |
![]() | m_Name | |
![]() | m_UserString | |
![]() | m_Valid | |
![]() | m_Value |