IGH_Component Interface |
Namespace: Grasshopper.Kernel
The IGH_Component type exposes the following members.
Name | Description | |
---|---|---|
InConstructor |
Gets the constructor flag for this instance. If InConstructor = True,
it means the component is still registering parameters and the
layout is not yet complete.
IsPreviewCapable |
Gets a value indicating whether or not this object (in its current state) can
IsValidMasterParameterIndex |
Gets whether the MasterParameterIndex property identifies a valid parameter.
MasterParameterIndex |
Gets or sets the master parameter index override.
Negative indices or indices larger than or equal to the input parameter count will
be ignored and regular master parameter detection will kick in.
| |
Message |
Gets or sets a custom message to be displayed underneath the component.
Params |
Gets the Params object that managed input and output parameters.
RunCount |
Gets a value indicating how many times the SolveInstance method was called on this component during the last solution.
This property will return -1 if no valid runcount is available.
Name | Description | |
---|---|---|
ClearData |
This function is called whenever the object needs to
clear all solution data. This usually amounts to wiping volatile caches and messages.
This function will not affect any other objects, but it will set the Phase flag to
CollectData |
This function is called whenever the object is required to collect
all data. Either from Persistent records, from source params or whatever.
This step is only performed if the phase flag is Blank or Failed.
ComputeData |
This function is called whenever the object is required to generate new data.
This step is only performed by some objects and only when the Phase flag is Collected.
Upon completion, the Phase will be Computed. If this object throws exceptions,
DrawViewportMeshes |
Implement this function to draw all shaded meshes.
RegisterRemoteIDs |
If this object depends on Rhino Objects, you must register the UUIDs of those objects.