IGH_Component Methods |
The IGH_Component type exposes the following members.
Name | Description | |
---|---|---|
ClearData |
This function is called whenever the object needs to
clear all solution data. This usually amounts to wiping volatile caches and messages.
This function will not affect any other objects, but it will set the Phase flag to
CollectData |
This function is called whenever the object is required to collect
all data. Either from Persistent records, from source params or whatever.
This step is only performed if the phase flag is Blank or Failed.
ComputeData |
This function is called whenever the object is required to generate new data.
This step is only performed by some objects and only when the Phase flag is Collected.
Upon completion, the Phase will be Computed. If this object throws exceptions,
DrawViewportMeshes |
Implement this function to draw all shaded meshes.
RegisterRemoteIDs |
If this object depends on Rhino Objects, you must register the UUIDs of those objects.