IGH_PreviewObject Interface |
Namespace: Grasshopper.Kernel
The IGH_PreviewObject type exposes the following members.
Name | Description | |
---|---|---|
ClippingBox |
Gets the clipping box for this object. The clipping box
is typically the union of the boundingboxes of all the
geometry that is drawn by this object.
| |
Hidden |
Gets or sets a value indicating whether or not this object is currently drawing preview flags.
| |
IsPreviewCapable |
Gets a value indicating whether or not this object (in its current state) can
draw geometric previews at all.
|
Name | Description | |
---|---|---|
DrawViewportMeshes |
Implement this function to draw all shaded meshes.
If the viewport does not support shading, this function will not be called.
| |
DrawViewportWires |
Implement this function to draw all wire and point geometry previews.
|