GH_RelevantObjectData Class |
Namespace: Grasshopper.Kernel
The GH_RelevantObjectData type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_RelevantObjectData |
Construct a new instance.
|
Name | Description | |
---|---|---|
![]() | Attributes |
Gets the attributes that belong to the object.
|
![]() | Group |
Gets the cast of the DocObject to GH_Group.
|
![]() | IsTopLevelObject |
Gets a value indicating whether or not the Object is a top-level object.
|
![]() | Object |
Gets the raw object cached in this data instance.
|
![]() | ObjectType |
Gets the type of object indicated by this data.
|
![]() | Parameter |
Gets the cast of the DocObject to IGH_Param.
If the DocObject is not of type IGH_Param, the
attributes of the object will be perused to find a
nested IGH_Param at the point.
|
![]() | Point |
Gets the point for which this GH_RelevantObjectData has been made.
|
![]() | TopLevelObject |
Gets the top-level object.
|