GH_PersistentParamT Class |
Namespace: Grasshopper.Kernel
The GH_PersistentParamT type exposes the following members.
Name | Description | |
---|---|---|
GH_PersistentParamT(GH_InstanceDescription) | Initializes a new instance of the GH_PersistentParamT class | |
GH_PersistentParamT(GH_InstanceDescription, Boolean) | Obsolete. Initializes a new instance of the GH_PersistentParamT class | |
GH_PersistentParamT(String, String, String, String, String) | Initializes a new instance of the GH_PersistentParamT class |
Name | Description | |
---|---|---|
Attributes |
Gets or sets the attributes that are associated with this object.
ComponentGuid |
Returns a consistent ID for this object type. Every object must supply a unique and unchanging
DataType |
Gets the type of data stored in this parameter.
Exposure |
Gets the exposure of this object in the Graphical User Interface.
HasProxySources |
Gets a value indicating whether or not this parameter maintains proxy sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
Icon |
Override this function to supply a custom icon (24x24 pixels). The result of this property is cached,
IconCapableUI |
By default the NickName menu item supports the Icon Mode override toggle.
If your UI is not capable of displaying icons, then override this property
IsPrincipal |
Gets whether this parameter is a principal parameter.
Keywords |
Gets a list of additional keywords that describe the object. Typically this list is empty but you
MutableNickName |
Gets or sets a value that enables Nick name changes through the menu.
Obsolete |
Gets whether this object is obsolete. Default implementation returns true if
the class name contains the string "OBSOLETE" or if this class has been decorated with the
Optional |
Gets or sets whether or not this parameter is considered optional by the owner component.
PersistentData |
Gets the persistent data stored in this parameter.
If you modify the persistent data, be sure to call the:
OnObjectChanged(GH_ObjectEventType.PersistentData)
event.
| |
PersistentDataCount |
Gets the number of persistent data items stored in this parameter.
ProxySourceCount |
Gets the number of proxy sources for this parameter.
Proxy sources are used during file IO, when actual sources might not be available yet.
Recipients |
Gets a list of all the recipients of this parameter.
I.e. a recipient has this parameter as one of the sources.
The Recipient list is maintained by the parameter,
Sources |
Gets a list of source parameters. Do not modify this list,
if you wish to add or remove sources, use dedicated functions
StateTags |
Gets all the StateTags that are associated with this parameter.
TypeName |
Calls TypeName() on the first instance of T it can find.
WireDisplay |
Gets or sets the wire display style for this parameter.
Name | Description | |
---|---|---|
AddRuntimeMessage |
Add a new message to this object. Valid message type flags are Warning and Error.
AddSource(IGH_Param) |
Append a new Source parameter to the end of the Sources list.
AddSource(IGH_Param, Int32) |
Insert a new Source parameter into the Sources list.
Cast_Object |
Attempts to convert the Object reference into an instance of T.
This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist.
ConversionCallback |
This method is called whenever a successful conversion takes
place from some source data into local target data.
DestroyIconCache |
Call this method to erase the existing icon cache.
ExpirePreview |
Call this function when you suspect that the preview has expired for this object.
ExpireSolution |
Informs the document that owns this object that the solution has expired.
The current object will be set to BLANK as a result. This method is recursive,
it will also expire any and all objects which depend on this object.
If you want a less destructive expiration, consider using ClearData().
HtmlHelp_Source |
Return a String which contains HTML formatted source for the help topic.
If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so:
Menu_AppendDestroyPersistent | ||
Menu_AppendExtractParameter | ||
Menu_AppendInternaliseData | ||
Menu_AppendObjectName |
Appends the old-fashioned object name menu item. If you also want the
Menu_AppendPromptMore | ||
Menu_CreateMultilineTextEditItem |
This function returns a ToolstripMenuItem that embeds a multi-line textbox
for editing persistent data. Only call this method if you know that your
parameter type supports proxies.
| |
Menu_CustomMultiValueItem | ||
NewInstanceGuid(Guid) |
Set the instance ID to be a specific GUID. This is very dangerous, only use this function
OnPingDocument |
Raise the PingDocument Event on the toplevel object and try to find
OnSolutionExpired |
Raises the SolutionExpired event on the toplevel object.
OnVolatileDataCollected |
Once volatile data has been collected this method will be calles. The basic
implementation does nothing, but you can add code here to post-process or
PreferredCast |
Implement this function if you're certain that you'll be confronted with very common casts.
For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number
Preview_DrawMeshes |
This function can be used to iterate over all items in the Volatile data tree
and call DrawViewportWires on each item that implements Preview.IGH_PreviewData.
This function requires a lot of TypeOf and DirectCasting,
Preview_DrawWires |
This function can be used to iterate over all items in the Volatile data tree
and call DrawViewportWires on each item that implements Preview.IGH_PreviewData.
This function requires a lot of TypeOf and DirectCasting,
Prompt_ManageCollection | ||
Prompt_Plural | ||
Prompt_Singular | ||
RecordPersistentDataEvent |
Add an undo record that stores changes to persistent data.
RegisterRemoteIDsUtil |
Utility function which treats all data in the Volatile cache as IGH_GeometricGoo
and registers all referenced objects. Call this function from within RegisterRemoteIDs()
RelinkProxySources |
Attempt to replace all proxy sources with real sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
RemovedFromDocument |
This method will be called when an object is removed from a document.
RemoveEffects |
Remove all post-process effects. Note to implementors,
ReplaceSource(Guid, IGH_Param) |
Replace an existing source with a new one. If the old_source
ReplaceSource(IGH_Param, IGH_Param) |
Replace an existing source with a new one. If the old_source
SetPersistentData(T) |
Add a single item to the persistent data.
This method will record an undo event, raise the OnObjectChanged event
for PersistentData flags and place a call to ExpireSolution(False).
If you want to add more than one piece of data, you should use the appropriate overload for this method.
| |
SetPersistentData(GH_StructureT) |
Assign a tree of items to the persistent data.
This method will erase any existing data,
record an undo event,
raise the OnObjectChanged event for PersistentData flags and
place a call to ExpireSolution(False).
If you want to add a tree of data, you should use the appropriate overload for this method.
| |
SetPersistentData(IEnumerableT) |
Assign a list of items to the persistent data.
This method will erase any existing data,
record an undo event,
raise the OnObjectChanged event for PersistentData flags and
place a call to ExpireSolution(False).
If you want to add a tree of data, you should use the appropriate overload for this method.
| |
SetPersistentData(Object) |
Add a collection of values to the persistent data.
ValuesChanged |
Override this method if you want to respond to changes to the value table.
Name | Description | |
---|---|---|
Name | Description | |
---|---|---|