IGH_PreviewArgs Interface |
Namespace: Grasshopper.Kernel
The IGH_PreviewArgs type exposes the following members.
Name | Description | |
---|---|---|
![]() | DefaultCurveThickness |
Gets the curve thickness as defined by the viewport display scheme.
|
![]() | Display |
Gets the Pipeline that is being used to draw the current preview.
|
![]() | Document |
Gets the Grasshopper document that is currently drawing the preview.
|
![]() | MeshingParameters |
Gets the meshing parameters to be used during meshing breps.
|
![]() | ShadeMaterial |
Gets the document default material for unselected Faces.
|
![]() | ShadeMaterial_Selected |
Gets the document default material for selected Faces.
|
![]() | Viewport |
Gets the Viewport in which the current preview is drawn.
|
![]() | WireColour |
Gets the document default colour for unselected Wires.
|
![]() | WireColour_Selected |
Gets the document default colour for selected Wires.
|