GH_DebugDescriptionWriter Class |
Namespace: Grasshopper.Kernel
The GH_DebugDescriptionWriter type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_DebugDescriptionWriter | Initializes a new instance of the GH_DebugDescriptionWriter class |
Name | Description | |
---|---|---|
![]() | Depth |
Gets the depth of the current writer.
Depth is represented by whitespace in front of each line.
|
Name | Description | |
---|---|---|
![]() | CloseBlock |
Close the current block and decrease the depth by 1.
|
![]() | CreateBlock |
Begin a new block. This will increase the depth by 1.
You must call CloseBlock() if you call this function.
|
![]() | CreateLog |
Get a single string that represents the entire log so far.
|
![]() | WriteLine |
Write a new blank line to the log.
|
![]() | WriteLine(String) |
Write a new line to the log.
|
![]() | WriteLine(String, Object) |
Write a new formatted line to the log.
|
![]() | WriteLogToFile |
Write the log to a text file.
|