GH_PreviewUtil Class |
Namespace: Grasshopper.Kernel
The GH_PreviewUtil type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_PreviewUtil | Initializes a new instance of the GH_PreviewUtil class |
![]() | GH_PreviewUtil(Boolean) | Initializes a new instance of the GH_PreviewUtil class |
Name | Description | |
---|---|---|
![]() | Enabled |
Gets or sets the enabled state of this Preview util.
|
![]() | WireColour |
Gets or sets the colour to use for Preview geometry.
|
Name | Description | |
---|---|---|
![]() | AddBox |
Add a box to the temporary Preview lists.
|
![]() | AddBrep |
Add a brep to the temporary Preview lists.
|
![]() | AddCurve |
Add a curve to the temporary Preview lists.
|
![]() | AddLine |
Add a line to the temporary Preview lists.
|
![]() | AddMesh |
Add a mesh to the temporary Preview lists.
|
![]() | AddPlane |
Add a plane to the temporary Preview lists.
|
![]() | AddPoint |
Add a point to the temporary Preview lists.
|
![]() | AddVector |
Add a vector to the temporary Preview lists.
|
![]() | Clear |
Clear all temporary geometry.
|
![]() | Dispose | Releases all resources used by the GH_PreviewUtil |
![]() | Redraw |
Forces a redraw the the viewports.
|