IGH_TaskCapableComponent Interface |
Namespace: Grasshopper.Kernel
The IGH_TaskCapableComponent type exposes the following members.
Name | Description | |
---|---|---|
InConstructor |
Gets the constructor flag for this instance. If InConstructor = True,
it means the component is still registering parameters and the
layout is not yet complete.
(Inherited from IGH_Component.) | |
InPreSolve |
Is set to True by the framework right before a "use tasks" pass is made on
SolveIntance calls. When True, SolveInstance should be using Tasks to start
calculations on input data. When False, SolveInstance should be setting the
output data by either using the result of a task or directly computing the
results.
| |
IsValidMasterParameterIndex |
Gets whether the MasterParameterIndex property identifies a valid parameter.
(Inherited from IGH_Component.) | |
MasterParameterIndex |
Gets or sets the master parameter index override.
Negative indices or indices larger than or equal to the input parameter count will
be ignored and regular master parameter detection will kick in.
(Inherited from IGH_Component.) | |
Message |
Gets or sets a custom message to be displayed underneath the component.
(Inherited from IGH_Component.) | |
Params |
Gets the Params object that managed input and output parameters.
(Inherited from IGH_Component.) | |
RunCount |
Gets a value indicating how many times the SolveInstance method was called on this component during the last solution.
This property will return -1 if no valid runcount is available.
(Inherited from IGH_Component.) | |
UseTasks |
Returns True if the component is set to support tasks. Components can have this
feature turned on/off. Note that even if UseTasks returns True, there is a chance
that a multipass task based solution may not be invoked depending on if multiple
calls need to be made during enumeration. You must pay attention to the value of
InPreSolve during SolveInstance.
The set version of this property can be called by the framework if we want to
provide a technique to globally turn on/off task support for all components in
a definition.
|
Name | Description | |
---|---|---|
RequestTaskCancellation |
Called by the framework when solving has been interrupted and tasks do not need to complete.
|