GH_DocumentServer Class |
Namespace: Grasshopper.Kernel
The GH_DocumentServer type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_DocumentServer | Initializes a new instance of the GH_DocumentServer class |
Name | Description | |
---|---|---|
![]() | Document |
Gets the document at the given index.
|
![]() | DocumentCount |
Gets the number of documents stored in the global list.
|
![]() | DocumentNames |
Gets a string collection containing all the names of the documents in the global list.
|
![]() | ModifiedDocumentCount |
Gets the total number of modified (unsaved) documents.
|
Name | Description | |
---|---|---|
![]() | AddDocument(GH_Document) |
Add a new document to the global list. If the document is already registered nothing will happen.
|
![]() | AddDocument(String, Boolean) |
Add a new document to the global list. If there already is a document with the
given path, it will be made active.
|
![]() | AddNewDocument |
Adds a new document to the global list. If a template file has been set, this document will be based on the template.
|
![]() | Contains |
Gets a value indicating whether or not the given document is inside the list.
|
![]() | GetEnumerator | |
![]() | GetEnumerator_Generic | |
![]() | IndexOf(GH_Document) |
Gets the index of the given document.
|
![]() | IndexOf(String) |
Gets the index of the document that matches the filepath.
|
![]() | IndexOfAutoSave |
Gets the document index that is associated with the specified autosave location.
|
![]() | NextAvailableDocument |
Gets the most important, non-active document.
|
![]() | PromoteDocument |
Push a document to the top of the list, meaning it will be first in
line when a new default document needs to be selected.
|
![]() | RemoveAllDocuments |
Remove all documents in the global list.
|
![]() | RemoveDocument |
Removes a specific document from the global list.
If the document isn't registered nothing will happen.
If the document is owned by an IGH_DocumentOwner,
the owner will be informed of the removal.
|
![]() | SafeRemoveDocument |
Remove a document correctly from the server.
This method shows user-interface prompts if there is unsaved data
and will also save if needed.
|
Name | Description | |
---|---|---|
![]() | DocumentAdded | |
![]() | DocumentRemoved |