Click or drag to resize

GH_DocumentServerAddDocument Method (GH_Document, Boolean)

Add a new document to the global list. If the document is already registered nothing will happen. This also applies to a different document which points to the same file path

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void AddDocument(
	GH_Document document,
	out bool success
)

Parameters

document
Type: Grasshopper.KernelGH_Document
Document to add.
success
Type: SystemBoolean
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the document is a null reference.
InvalidOperationExceptionThrown when the document doesn't have top-level rank.
See Also