GH_StateServer Class |
Namespace: Grasshopper.Kernel
The GH_StateServer type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_StateServer | Initializes a new instance of the GH_StateServer class |
Name | Description | |
---|---|---|
![]() | Names |
Gets a list of all the state names in this server.
|
![]() | Owner |
Gets the document that owns this server.
|
Name | Description | |
---|---|---|
![]() | NewStateFromDocument |
Displays UI for new state creation. If the user aborts, then null is returned.
If the user successfully defines a new state, it is appended to this server.
|
![]() | Read | |
![]() | RemoveState |
Remove a certain state. This method adds an undo record to the document.
|
![]() | RestoreState(Int32, Int32, Int32) |
Restore a certain state.
|
![]() | RestoreState(String, Int32, Int32) |
Restore a certain state.
|
![]() | RestoreState(Int32, Boolean, Int32, Int32) |
Restore a certain state.
|
![]() | Write |