GH_ExternalFile Class |
Namespace: Grasshopper.Kernel
The GH_ExternalFile type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_ExternalFile |
Create a new instance of the file info class
|
Name | Description | |
---|---|---|
![]() | FileHash |
Gets the file hash.
|
![]() | FileName |
Gets the file name (without the extension).
|
![]() | FilePath |
Gets the file path.
|
![]() | FileSize |
Gets the file size (in bytes).
|
![]() | FileType |
Gets the file type as indicated by the extension.
|
Name | Description | |
---|---|---|
![]() | IsIdenticalTo |
Compares two files for content. If the size and the hash or the other file are equal to this one, the files are considered identical.
|