Click or drag to resize

GetTransform Class

Used for getting a Transform
Inheritance Hierarchy

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class GetTransform : GetPoint

The GetTransform type exposes the following members.

Constructors
  NameDescription
Protected methodGetTransform
Initializes a new instance of the GetTransform class
Top
Properties
  NameDescription
Public propertyHaveTransform
Public propertyObjectList
Public propertyTransform
Top
Methods
  NameDescription
Public methodAddTransformObjects
Adds any objects you want transformed and grips you want transformed. Make sure no duplicates are in the list and that no grip owners are passed in as objects.
Public methodCalculateTransform
Retrieves the final transformation.

Override this virtual function to provide your own custom transformation method.

Public methodGetXform
Gets the Transformation.

Call this after having set up options and so on.

Top
Events
  NameDescription
Top
See Also