Click or drag to resize

GetBaseClassGetSelectedEnumValueFromSelectionListT Method

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.4
Syntax
public T GetSelectedEnumValueFromSelectionList<T>(
	IEnumerable<T> selectionList
)
where T : struct, new(), IConvertible

Parameters

selectionList
Type: System.Collections.GenericIEnumerableT

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:Rhino.Input.Custom.GetBaseClass.GetSelectedEnumValueFromSelectionList``1(System.Collections.Generic.IEnumerable{``0})"]

Exceptions
ExceptionCondition
ArgumentExceptionGets thrown if type T is not an enumerated type.
IndexOutOfRangeExceptionIf 0 >= CurrentListOptionIndex or CurrentListOptionIndex > N where N is the number of enumerated values.
See Also